Frequently Asked Questions logo
Frequently Asked Questions logo

All articles

What browser version is needed to complete the lab registration process?Updated 8 months ago

The following browser types and versions are supported:

  • Safari versions 15+
  • Chrome versions 107+
  • Edge versions 119.0.2151.72+
  • Firefox versions 120.0+


Note: The DuckDuckGo browser is not supported at this time.



Was this article helpful?
Yes
No